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EasyRemotelO L_| WE!NTEK

1. Overview

EasyRemotelO is a tool designed for configuring Weintek iR-ETN/iR-ETN40R devices.
Through the EasyRemotelO interface, users have the capability to configure
iR-ETN/iR-ETN40R’s IP address and various parameters, and monitor or modify
device values. Additionally, the export feature of EasyRemotelO facilitate users,
especially those using EasyBuilder Pro, CODESYS, or EtherNet/IP devices, in
generating essential files for establishing a connection with iR-ETN/iR-ETN40R.

2. Quick Start

1. Launch EasyRemotelO, click on [Automatic Scan].

&7 EasyRemotelO (= |EoR ==

Ele Edit View Online Tools Help
W =229 |@EN B H BB

Profect Window 8 | Automatic Scan

AddressMop | Parameter

Channel Name Type Online Value Froject Value

Log Message J X

Date Time Message

2018-02-07 16:10:30.753 EasyRemotelO is started. ProductVersion:1.0.0.0

2. Select [Overwrite the project], and click [Scan]. The default IP of
iR-ETN/iR-ETN4OR is 192.168.0.212. Please make sure the PCis in the same
domain: 192.168.0.*.*,
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Automatic Scan @
Mame IP Address Mac Address Sub Mask
@ Owerwrite the project
(7 Add to project
Sran
4 nr
o
3. TheiR-ETN/iR-ETN4OR can be found in Automatic Scan window. Select the
iR-ETN/iR-ETN40R you want to configure and click OK.
Automatic Scan @
Mame IP Address Mac Address Sub Mask )
> [ iR-ETN 1921682183  00-0C-26-01-02-04 255.255.252.0 | @ Overwrite the project
- [[] TONY2 1021681136  00-0C-26-12-34-5B 2552552520 | ) add 1o project
> [F] TONYL 1921681138  00-0C-26-12-34-5A 255.255.252.0
Sran
4 nr
OK | [ Comel |
4. The iR-ETN/iR-ETN4OR and the module’s information will be shown as below.
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&7 EasyRemotsl0 E=5|ECR |

Eile Edit View Online Tools Help

W 2SSy BB BE

Project Window 8 X
10/Modulss | Addressblap | Pavameter
- iR-ETN (192.168.2.183)
@ #1iR-DM16-P Channel Nome Type Online Valoe Project Value
4 iR-ETN (192.168.2.183)
#1:iR-DM16-P DI/ DO 0x00
Log Message & X
Date Time Message
2018-02-07 16:21:28.500 Auto scan is successfully completed.
2018-02-07 16:10:30.753 EasyRemaotelQ is started. PraductVersion:1.0.0.0

Select [Change IP] under [Online] to change the IP address of iR-ETN/iR-ETN40R
and then click OK.
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P P ==
File  Edit View[m'ruo\s Help
Eg) @ Automatic Scan shiftes K] B B
Project Window 0Z] Compare with Offline Shift+C
Address Map Pararmeter
4 0 R-ETN (19 B Download
| = Cmline Valoe Project Value
B el T I ———
[]:ﬂ Copy to Project —
Special Commands Ict code
Change IP ame iR-ETN
are revision
E‘?. Start Manitoring Shift+M |2 o (ovision
Eﬂ Stop Monitaring Shift+0 consumption
TUrrEnt power consumption
Power supply
Life guard time 0
iBus continue run ON
MNumber of TCP connected

Mumber of modules
Point Of Digital input
Point Of Digital output
Mumber Of Analog input
Mumber Of Analog output

Log Mesmage 5 x
Date Time Message
2018-02-07 16:21:28.500 Auto scan is successfully completed

2018-02-07 16:10:30.753 EasyRemotelQ is started. ProductVersion:1.0.0.0

ChangeIP address IE'

Mar: Address: 00-0C-26-01-02-04
IPAddress: 192 | 168 2 183

SubMssk: 355 255 252 O

[ ox [ Comel

6. Inthe Project Window, select an iR-ETN/iR-ETN40R and then go to [Parameter]
tab in the right column. Here you can change the related parameters of
iR-ETN/iR-ETN40R. The actual value of iR-ETN/iR-ETN4O0R is in the [Online Value]
column. The new value should be entered in the [Project Value] column.
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&7 EasyRemotel0 o o=
file Edit View Online Tools Help
HEZEe B EEHBE
Project Window
[ 10/ Modules | AddmssMap | Pavameter
4 | iR-ETN (192.168.2.183)
i #1 iR-DM16-P Chave] Naime Cinline Value Project Value
4 iR-ETM (192.168.2.183)
Vendor name
Product code
Host name iR-ETN
Firmware revision
Hardware revision
Power consumption
Current power consumption
Power supply
Life guard time o
iBus continue run ON
Mumber of TCP connected
MNumber of modules
Paint OF Digital input
Point Of Digital output
Mumber Of Analog input
Mumber Of Analog output
Log Mesmage 5 X
Date Time Message
2018-02-07 16:47:13.631 Auto scan is successfully completed
2018-02-07 16:21:28.500 Auto scan is successfully completed
2018-02-07 16:10:30.753 EasyRemotelQ is started. ProductVersion:1.0.0.0
7.  Click [Upload] to read the data from iR-ETN/iR-ETN40R and show in

EasyRemotelO.

Click [Download] to write the data in EasyRemotelO to iR-ETN/iR-ETN40R.

Parameter

Eile Edit View Online Tools Help

BB PR =5 @ W EE
Project Wind & X

e R 10/M.UPI92d B 3dress Mop
File Edit View Online Toals Help

BB W = @80 K
Project Window

B &

10 Mod _D-:uwnlu:ad ‘bdap Parameter

8. Select the module connected to iR-ETN/iR-ETN40R in Project Window. In the
I0/Modules tab you can read/write inputs and outputs value. Click [Download]
to write the data from EasyRemotelO to iR-ETN/iR-ETN40R.
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ﬁﬂEasyRemoteIG
file Edit View Online Tools Help

CREFERE==

G BB B E

Project Window 5 X
10/Modules | AddressMsp | Paameter |
4 [l iR-ETM (192.168.2.183)
il #1iR-DM16-P Chanmel Name Type Online Falue Project Value
4 #1:iR-DM16-P
Digital Input %0 DI
Digital Input #1 01
Digital Input #2 oI
Digital Input #3 DI
Digital Input #4 01
Digital Input #5 DI
Digital Input #6 01
Digital Input #7 oI
Digital Output #0 ple) 0
Digital Qutput #¥1 Do o
Digital Output #2 DO 0
Digital Qutput #3 oo 0
Digital Output #4 DO 0
Digital Qutput #5 Do 0
Digital Qutput #6 Do o
Digital Output #7 DO 0
Log Mesmage 5 X
Date Time Message

2018-02-07 16:47:13.631 Auto scan is successfully completed

2018-02-07 16:21:28.500 Auto scan is successfully completed

2018-02-07 16:10:30.753 EasyRemotelQ is started. ProductVersion:1.0.0.0

9. The parameters of the modules can be changed in Parameter tab.

ﬁﬂEasyRemoteIG
file Edit View Online Tools Help

CREFERE==

G BB B E

[ 10/ Modules | AddmssMap | Pavameter

Project Window

4 [l iR-ETM (192.168.2.183)
il #1:iR-DM16-B Chanmel Name Omling Valve Project Value i
4 #1:iR-DM16-P
Digital input filter time #0 o
Digital input filter time #1 o
Digital input filter time #2 o
Digital input filter time #3 0
Digital input filter time #4 o
Digital input filter time #5 0 C
Digital input filter time #6 o
Digital input filter time #7 o
Digital autput error mode #0 Errarvalue
Digital cutput error mode #1 Errar value
Digital output error mode #2 Error value
Digital output error mode #3 Error value L4
Digital output error mode #4 Error value
Digital output error mode #5 Error value
Digital cutput error mode #6 Errar value
Digital autput eror mode #7 Error value
Digital output error value ¥0 Low
Dinital autout eror value #1 Low =
Log Mesmage 5 X

Date Time Message

2018-02-07 16:47:13.631 Auto scan is successfully completed
2018-02-07 16:21:28.500 Auto scan is successfully completed

2018-02-07 16:10:30.753 EasyRemotelQ is started. ProductVersion:1.0.0.0
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3. Settings
Edit
Add

Network Coupler: Add network coupler manually.

Module: Add module manually.

Online

Automatic Scan

Scan all the iR-ETN/iR-ETN4OR in the same domain.

Compare with Offline

Check whether the devices in EasyRemotelO exist in the same domain.

Compare with Offline [ == |
Item Offline Value Online Value
#2: Mon-exist online iR-DI16-K X
EasyRemotelO @ Start Compare
Comparision completed. Configuration is different. Target: iR-COP
! b, (192.168.1.225)
[ ok || consl
Download

Write the value from EasyRemotelQ’s Project Value column to the iR-ETN/iR-ETN40R.
Upload

Read the value from iR-ETN/iR-ETN4OR and show it in EasyRemotelO’s Online Value
column.

Copy to project

Read the value from iR-ETN/iR-ETN40OR and show it in EasyRemotelO’s Online Value
and Project Value columns.
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10/ Modules Address Map | Parameter
Channel Namme Tyvpe Online ¥alue Project Value
4 #1:iR-DM16-P

Digital Input #0 DI 0
Digital Input #1 oI 0
Digital Input #2 oI 0
Digital Input #3 oI 0
Digital Input #4 oI 0
Digital Input #5 DI 0
Digital Input #6 oI 0
Digital Input #7 oI 0
Digital Qutput #0 DO 0 0
Digital Output #1 DO 0 0
Digital Output #2 DO 0 0
Digital Qutput #3 DO 0 0
Digital Qutput #4 DO 1 1
Digital Qutput #3 DO 0 0
Digital Output #6 DO 0 0
Digital Qutput #7 DO 0 0

Special Commands

Restart Device: Restart iBus and module.

Restart iBus: Restart iBus only.

Reset to default (except IP setting): Reset all the parameters, except IP settings, to

default.

Special Commands

Restart Device
Restart iBus
Reset to default{except IP Setting)

x5

Hend

Change IP

Change the IP address of iR-ETN/iR-ETN40R.

Change IP address @
Mac Address : 00-0C-26-04-05-06
IP hddress: 192 168 1 225
SubMask: 255 255 252 O
OK i | Cancel
8
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Start Monitoring

Start monitoring iR-ETN/iR-ETN4OR. (Read only)
Stop Monitoring

Stop monitoring iR-ETN/iR-ETN4O0R.

Tools
Modbus
Allows users to run an online MODBUS TCP/IP client on the PC.

i =

Modbus Communication

Communication Setup

IF Address ; 192 . 168 . 1 . 40 SlaveID: |0

Protocol :  |Modbus TCP

Pre_defined : [[1.F‘.ead] Digital input T] [ ]
Function :  Read Disrete Inputs -
Address: 0 Quantity 1 1

Response

Hex Dec ASCII BIM
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4. Analog Module
Displaying Channel Value

I__“v WE!NTEK

All channel values are displayed when clicking the [Start Monitoring] button in the

I0/Modules tab.

Address Map Parameter

Channel Name Type Cinling Value Froject Value
W #3iR-Al04-VI
Analog Input #0 Al 0
Analog Input #1 Al 0
Analog Input #2 Al 0
Analog Input #3 Al 0
Writing Channel Value

All channel values are displayed when clicking the [Start Monitoring] button in the

I0/Modules tab.

Specify [Project Value] and then click [Download], the specified value will be written

into [Online Value].

0/ Modvles  Address Map Parameter

Channel Name Type Cinline Valve Froject Value
o F2iR-ACM-VI

Analog Qutput #1 AO 0 0
Analog Qutput #2 A 0 0
Analog Output #3 AC 0 0

Configuring Parameters

Click [Upload All] to read all parameters which are displayed in the Parameter tab.

10/ Modulss  Address Map

Chamnmel Name Online Vale Project Falve ~
¥ #3IR-AI-VI
Product Code (425
Firmware Revision 1.0.00
Hardware Revision 1.0.00
Power Consumption 035W
Point of Digital Input 0
Point of Digital Output 0
MNumber of Analog Input 4
MNumber of Analog Output 0
Input Mode #0 Close Close v
Input Mode #1 Close Close =
Input Mode #2 Close Close v
Input Mode #3 Close Close ~
Input Scale Range Upper Limit #0 32000 32000
Input Scale Range Upper Limit #1 32000 32000

Change channel parameter under [Project Value].

10
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10/ Modules Address Map Parameter

Channel Name Onling Value Project Value L
¥ #3iR-Al-VI
Product Code w0425
Firmware Revision 1.0.0.0
Hardware Revision 1.0.0.0
Power Consumption 0.35W
Point of Digital Input 0
Point of Digital Qutput 0
Mumber of Analoeg Input 4
Mumber of Analog Output 0
pitbodeso — cee G 3|
Input Mode #1 Close Close =
Input Mode #2 Close Close =
Input Mode #3 Close Close
Input Scale Range Upper Limit #0 32000 32000
Input Scale Range Upper Limit #1 32000 32000

Click [Download] to write from [Project Value] into [Online Value].

10 /Modules  Address Map Parameter

Channel Name Online Value Praject Value G
v ERR-AI-VI

Product Code 00425

Firmware Revision 1.0.0.0

Hardware Revision 1.0.0.0

Power Consumption 0.35W

Point of Digital Input 0

Point of Digital Qutput 0

MNumber of Analog Input 4

MNumber of Analog Output 0

Input Mode #1 ose Close ~
Input Mode #2 Close Close ~
Input Mode #3 Close Close ~
Input Scale Range Upper Limit 20 32000 32000

Input Scale Range Upper Limit #1 32000 32000

s For more information about channel parameters, see chapter 6 in
UMO018013E_iR-Axxx-VI_UserManual_20190401_eng.

s Settings in the Parameter tab are written into the analog module’s registers.

A faster way to start analog module is to configure the parameters using
EasyRemotelO and then import the settings on the coupler.

11
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Initializing Module

[Online] » [Special Commands]

Select the analog modules to be initialized, and then click [Send] to restore factory
default.

Special Commands =

Restart Device

Restart iBus

Reset to default(except IP Setting)

Reset to manufacture value (#2: iR-AC004-V1)
Reset to manufacture value (3 1R-4104-YT)
Reset to manufacture value (4: IR-AI04-TR) send
Reset to manufacture value (7 iR-4104-Y1)
Reset to manufacture value (28 iR-4AC004-VI)
Reset to manufacture value (#17: iR-ACM-Y)
Rezet to manufacture value (#13: iR-ACM-Y)

Cancel

12
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5. Export

Export Tag

When Weintek Remote IO (MODBUS TCP/IP) driver is selected in EasyBuilder Pro,
selecting [Export Tag] in EasyRemotelO can help users quickly build
iR-ETN/iR-ETN4OR related parameters.

1. Launch EasyRemotelO and select [File] » [Export Tag].

[H] EasyRemotelO - O X
File Edit View Online Tools Help
| Open Ctrl+0 EE‘- 12 E: EE[‘l mi EEE o0 og
(3 Mew Ctrl+N
- I0/Modules  AddmssMap  Permeter | Power Information
H save Ctil+s
B savehs Channe] ome Modbus Mapping Onling Valoe Project Valoe *
ExportTag v #1: iR-AMO6-VI
e Product Code 7530 00635
Firmware Revision 7531 1.000
ErriEnaiib ES Hardware Revision 7532 1000
Power Consumption 7533 035W
Point of Digital Input &T356 [
Point of Digital Output 7557 0
Mumber of Analog Input 7558 4
Mumber of Analog Output 7359 2
Analog Output Error Mode #0 0x1815[0] Error value Error value
Analog Output Error Mode #1 0x1815[1] Error value Error value
Analog Output Error Value #0 1819 [} [}
Analog Output Error Value £1 x181a 0 [}
Output Mode #0 Oxde20 =10V 10V
Output Mode #1 Oxde2] Close Close
Output Scale Range Upper Limit 0 xde2d 32000 32000
Output Scale Range Upper Limit £1 Oxde2s 32000 32000
Output Scale Range Lower Limit #0 Oxde28 -32000 -32000
Output Scale Range Lower Limit £1 xde29 -32000 -32000 v
< >

2. Launch EasyBuilder Pro and select [System Parameters] » [New Device] »
[Weintek Remote |0 (MODBUS TCP/IP)].

Device Properties

| Weintek Labs., Inc. - Search

Weintek Built4n CODESYS
Weintek Remote I0 (CAMNopen

Weintek Remote 10 (MODBLUS TCP

3. After importing tags, information about iR-ETN/iR-ETN4OR can be found when
creating an object.

—
X
Device : | weintek Remote 10 (MODBUS TCP/IP) v
Address type : | iR-ETN.Vendor Name
Addresg: |4
Q|
Address format : —
Name Data type Description &
[ iR-ETN.Vendor Name Undesignated
[ iR-ETN.Product Code Undesignated
[0 iR-ETN.Host Name Undesignated
*To make calcUlation { | [ 5p_ETN Firmware Revision Undesignated
conversion definition
TagLibrary... | | B iR-ETN.Hardware Revision Undesignated
- | | | B0 iR-ETN.Power Consumption Undesignated
?-ETN.Cur.rent Power Undesignated
onsumption
) iR-ETN.Power Supply Undesignated
D CTMI L fm Caimed To Llod v
Tag: |iR-EI'N.Vendor MName Ok

13
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Exporting PLCopenXML file can help users quickly build communication parameters
when establishing connection between a CODESYS device and an iR-ETN/iR-ETN40R.
1. Launch EasyRemotelO and select [File] » [Export PLCopenXML].

H

File Edit View

EasyRemotel0

Open Ctrl+0
New Ctrl+N
Save Ctrl+5
Save As

Export Tag

Export PLCopenXML

Export EtherNet/IP EDS

Online  Tools  Help

X

I0/Modules  AddvessMap  Porameter  Power Information
Chennel Name Modbus Mapping Online Velus Project Velue
v #1:iR-AMDE-VI
Product Code 0x7530 0x0635
Firmware Revision 07531 1.000
Hardware Revision 07532 1.000
Power Consumption 0x7533 035W
Point of Digital Input 0x7556 0
Point of Digital Output 07557 0
Mumber of Analog Input 0x7558 4
Mumber of Analog Output 07559 2
Analog Output Error Mode #0 0x115[0] Error value Error value
Analog Output Error Mode #1 0x1815[1] Error value Error value
Analog Output Error Value £0 0x1219 0 0
Analog Output Error Value £1 x181a 0 0
Output Mode #0 Oxde20 =10V Hov
Output Mode #1 Oxde2! Close Closs
Output Scale Range Upper Limit #0 Oxdedd 32000 32000
Output Scale Range Upper Limit #1 Oxde2s 32000 32000
Output Scale Range Lower Limit #0 Oxde28 -32000 -32000
Output Scale Range Lower Limit #1 Oxde29 -32000 -32000 v
< >

Select the device and set the file version to be exported. The file version should

be the same as that of the Modbus_TCP_Slave in CODESYS IDE. The version used

in the example below is 3.5.16.0.

Channel Select

<

iR-ETN (192.168.3.212)
(] iR-ETN (192.168.1.135)
(] iR-ETN (192.168.1.136)

Select All Unselect Al Export file version : [3.5.16.0

CK

Cancel

14
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[ Add Device x

Mame |Mndbus_TCP_SIaue

Action
(@) Append device () Insert device Flug device () Update device
|String for & full text search | Vendor | zall vendors> w
Mame Vendor Wersion Description
= ﬂi Fieldbuses
=/ Wil Modbus
= WEE Modbus TCP Slave
ﬂj |Mudbus TCP Slave 35 - Smart Software Solutions GmbH 3.5.16.0 A generic Modbus ¢
ﬂj Modbus TCP Slave 35 - Smart Software Solutions GmbH 4,1.0.0 A generic Modbus ¢
£ >
Group by category Display all versions (for experts only) [ ] Display outdated versions

Launch CODESYS, add [Ethernet] » [Modbus_TCP_Master] device.
Devices > 3 X
=[5 PLCopen¥ML -

= m Device (Weintek Built-n CODESYS)
=&l PLC Logic
= 0’ Application
m Library Manager
WF] PLC_PRG (PRG)
= @ Task Configuration
= @ MairTask
& PLC_PRG
= m Ethernet (Ethernet)
ﬁ |Mndbus_TCP_Master (Modbus TCP Master) |

Select [Project] » [Import PLCopenXML] to import PLCopenXML.

15
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Deiss - ax iR_ETN_192_168 3 212_ x
General Name Access Type Trigger READ Offset  Length  ErrorHandiing WRITE Offset  Length
0 1:RAMIENLAndogInput  Read Input Regters (Functon Code 04) Cydic, t4100ms 1620000 4+
Medbus Save Channel 1 IRAMOGVLAnsbgOUDUt  Read/Wirite Multple Regsters (Functon Code 23)  Cydc, t2100ms 1620100 2 due 1620100 2
Library Manager S, 2 2:RDMIEN.Digital Input Read Discrete Inputs (Function Code 02) Cydc, t£100ms 1620000 E Keep last Value
3 2:iR-DM16-N.Digital Output(R) Read Coils ) Cydic, t%100ms 160000 8 Keep last Value

ModbusTCPSlave Parameters 4 2 ROMI6-N.Digita Output(W)  Write Mt Cydic, t£100ms 1620000 8
ModbusTCPSlave 1/0 Mapping

Status

Information

5. After importing the file, the selected iR-ETN/iR-ETN40R can be found in the
CODESYS project with the read/write channels and parameters set.
= m Device (Weintek Built-in CODESYS)
=]l PLE Logic
=1L} Application
m Library Manager
PLC_PRG (PRG)
= @ Task Configuration
= 3% MainTask
& PLC_PRG
= ﬂj Ethernet (Ethernet)
= m Modbus_TCP_Master (Modbus TCP Master)
[ r_ETN_192_168_1_37_({Modbus TCP Slave)

Export EtherNet/IP EDS

Exporting EtherNet/IP EDS file can generate Electronic Data Sheets of
iR-ETN/iR-ETN4OR.

1. Launch EasyRemotelO and select [File] » [Export EtherNet/IP EDS].

EasyRemotelQ - O X
File | Edit View Online Tools Help
Open Curl+0 B e @B e R 3
3 New Ctrl=N a8 x
10 ¢ Modules Address Map Parameter Power Information
H save Cerl+S
B saveas Chanue] Haums Mofbus Mopping  Oaline Velue Project Value  *
I v #1; iR-AMOS-VI
eeoort PLComensiML Product Code 0x7530 0x0635
B B Firmuware Revision 07531 1000
ErrnEE Y E Hardware Revision 0x7532 1000
Power Consumption 0x7533 035W
Point of Digital Input 0x7556 0
Point of Digital Output 0x7557 0
Number of Analog Input 047558 )
Number of Analog Output 047559 2
Analog Output Errer Mode #0 0x1815[0] Error value Error value
Analog Output Error Mode #1 0x1815[1] Error value Error value
Analog Output Error Value 20 01819 0 0
Analog Output Error Value #1 ox181a 0 0
Output Mode 20 (x4e20 £10v Hov
Output Mode #1 Oxde2! Close Closs
OQutput Scale Range Upper Limit 20 Oxde24 32000 32000
Qutput Scale Range Upper Limit #1 Oxde25 32000 32000
Output Scale Range Lower Limit #0 Ox4e28 -32000 -32000
Output Scale Range Lower Limit #1 Ox4e29 -32000 -32000 A
< >

2.  Import EtherNet/IP EDS in the user interface of EtherNet/IP device. Please see
iR-ETN EtherNet/IP Connection Guide for more information.
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